Back to Question Center
0

लैंप स्टैक Semaltट - क्या कोई वेबसाइट या संस्करण ट्रैकर स्रोत है जो प्लेटफॉर्म स्टैक के प्रत्येक भाग के सही संस्करणों को सुझाए गए हैं?

1 answers:

अकेले लिया, अनुसंधान संस्करण और संगतता के लिए आसान है. मीडल जानकारी एक स्टेक के प्रत्येक एक भाग पर आसानी से उपलब्ध है, जैसे कि MySQL. आप नवीनतम संस्करण, स्थिर संस्करण का पता लगा सकते हैं, और कभी-कभी यहां तक ​​कि संस्करण द्वारा अपनाए जाने वाले लोगों का भी प्रतिशत (व्यक्तिगत तौर पर, मुझे गोद लेने की दर पर संख्या देखना पसंद है).

सेमील्ट, जब संस्करणों का सबसे अच्छा संभव मिश्रण खोजने की कोशिश कर रहा है, मेरे पास एक कठिन समय है. उदाहरण के लिए, "यदि आप MySQL 5 का प्रयोग कर रहे हैं - cheap virtual server hosting windows. 5, आपको PHP संस्करण XX या उच्चतर की आवश्यकता होगी. "

जब आप उच्च स्तरीय प्लेटफॉर्म को ड्रुपल, Semaltेट आदि जैसे मिश्रण में फेंकते हैं, तो इसे कम करने में और भी मुश्किल हो जाती है.

मैं "विज़ार्ड" पर विचार करता हूं जैसे इंस्टॉलर फायदेमंद हो, जैसे कि बिटनामी इंस्टॉलर. नमस्ते, मुझे हमेशा आश्चर्य होता है कि क्या उन समाधानों में कम से कम आम भाजक को पूरा किया जा सकता है - बहुत सारे लोग - और जैसे, मुझे लगता है कि मैं खुद को चीजों को स्थापित करना बेहतर होगा. इस तरह के समाधान नए संस्करणों को अपनाने में धीमी गति से लगते हैं, आवश्यक से धीमी, मुझे संदेह है.

क्या कोई वेबसाइट या उपकरण है जो एक वेबमास्टर को चुनने के लिए डाटा संस्करण को समेकित करता है जो स्टैक के अन्य सभी भागों के विचार में इंस्टॉल करने के लिए किन संस्करणों को तैनात करता है या कौन सा उन्नयन करता है?

February 8, 2018

क्या आप एक ऐसे स्रोत के लिए पूछ रहे हैं जो प्रत्येक ऐप के नवीनतम वर्तमान स्थिर संस्करण को दिखाता है? यदि हां, तो मुझे लगता है कि पैकेज प्रबंधकों के लिए क्या है.

तो बस अपनी पसंद के डिस्टो को चुनिए, उनकी वेबसाइट आपको नवीनतम बिल्ड पर बताएगी. फिर रन apt-get / yum और स्टैक के प्रत्येक भाग के नवीनतम स्थिर रिलीज़ को स्थापित करें. या, यदि आप उबंटु चला रहे हैं, तो आप एक बार में एएमपी भाग को स्थापित करने के लिए टास्कसेल का इस्तेमाल कर सकते हैं.

संपादित करें: मुझे नहीं लगता है कि कोई विशेष विचार (सीजीआई पर PHP को चलाने के लिए या एक मॉड्यूल के रूप में छोड़कर) आप इन पैकेजों के लिए आवश्यक हैं. एक WAMP स्टैक स्थापित करना थोड़ा और अधिक कठिन है, लेकिन लिनक्स पर आप नवीनतम स्थिर चुन सकते हैं और इसके साथ चल सकते हैं. यद्यपि यदि आपको PHP / MySQL और अपने वेब एप्लिकेशन के साथ संगतता समस्या है, तो आपको एक पुराने स्थिर चुनने की आवश्यकता हो सकती है.